July 16, 2018 | Brigitte Raumann

Globus uses the Transport Layer Security (TLS) encryption protocol to secure network communications. In keeping with recommended security practices, Globus is deprecating TLS 1.0 and TLS 1.1 and requiring a minimum of TSL 1.2. This security upgrade will roll out across all Globus services and downloads during the week of August 27, 2018.

We expect this change to impact only a very small number of users. If you have any questions or concerns, please contact support@globus.org.